vSphere CLI: http_proxy not set / ftp_proxy not set

Wenn man das vSphere CLI installieren möchte, bricht die Installation mit folgender Meldung ab:

http_proxy not set. please set environment variable 'http_proxy' e.g. export
http_proxy=<a href="http://myproxy.mydomain.com:0000" target="blank">http://myproxy.mydomain.com:0000</a> .
 
ftp_proxy not set. please set environment variable 'ftp_proxy' e.g. export
ftp_proxy=<a href="http://myproxy.mydomain.com:0000" target="blank">http://myproxy.mydomain.com:0000</a> .

Um dieses Problem zu lösen, muss man das vmware-install.pl script "patchen".

Suche nach folendem Abschnitt:

if ( !( $ftpproxy && $httpproxy)) {
  uninstall_file($gInstallerMainDB);
  exit 1;
}
require CPAN;

Und kommentiere die Zeilen: "uninstall_file", so wie das "exit 1" aus:

if ( !( $ftpproxy && $httpproxy)) {
  <b>#uninstall_file($gInstallerMainDB);</b>
  <b>#exit 1;</b>
 }
require CPAN;

Nun sollte die Installation klappen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.